首页>帮助中心>教程>服务器安装SG11扩展多版本(win/linux宝塔+手动通用版本)加密组件安装教程

此组别内的文章

  • 服务器安装SG11扩展多版本(win/linux宝塔+手动通用版本)加密组件安装教程

需要支持?

如果通过文档没办法解决您的问题,请提交工单获取我们的支持!

服务器安装SG11扩展多版本(win/linux宝塔+手动通用版本)加密组件安装教程

SG11是PHP的一个混淆加密组件,也是目前市面上相对最安全的PHP源码组件加密方式,被加密的源码必须安装该组件才可以正常运行,这里用图文介绍一下安装步骤。

整个安装过程非常简单,认真有点耐心就可以了。

如果你没有安装扩展,在使用插件的时候会有如下的错误提示:

未安装sg11扩展提示.png

宝塔面板用户安装

进入宝塔面板,点击软件管理,找到你网站对应的php如下图操作

找到对应PHP版本.png

找到后点击设置 安装扩展 找到sg11  安装即可

3、安装扩展.png

可以看到这样扩展就安装成功了。

4、安装成功.png

其他服务器或面板手动安装教程

首先下载SG11组合集.zip(sg11.4)
也可以直接去官网下载

  1. 解压都得到一堆文件,对应你自己的服务器,windows,Linux等,这里我们以windows为例,打开Windows 64-bi t我们找到对应我们服务器配置的文件夹
  2. 可以看到有很多文件,我现在用的是PHP5.4我们就选择5.4的.win文件
  3. 然后打开php.ini大约在850行左右在同类型的参数下再添加一条 extension=ixed.5.4.win 一般性php扩展都是放在ext目录的
  4. 没有的可以查找一下extension_dir 如果有类似下图的定向一个目录的参数,直接将index.5.4.win 放到定向的目录里即可
  5. 如果连ext和定向目录都没有可以自定义存放目录 手动调用目录格式,直接将E:\phpstudy\PHPTutorial\php\php-5.4.45\ext\index.5.4.win 目录只是示例,按照你自己存放SG文件的路径来,需精准的调用地址,Linux可能需要将 \ 换为 /

一切准备就绪后需重启一下服务器或重启一下php即可,其实道理都是一样的,把ixed的文件放在自己服务器的一个目录下,再在php.ini里设置好他的路径然后重启就行了

#宝塔面板PHP7.x安装后出现版本低的解决方法

部分源码使用了高版本组件加密和7.x自带的不符,需要手动修改替换为高版本组件

首先下载组件文件:SG11.3.zip

  1. 解压都得到一堆文件,对应你自己的服务器,windows,Linux等,这里我们以Linux为例,打开Linux 64-bit找到对应我们服务器配置的文件夹

  2. 可以看到有很多文件,我现在用的是PHP7.2我们就选择7.2的.lin文件

  3. 宝塔面板打开php.ini配置文件搜索ixed看一下默认组件路径

  4. 上传替换掉默认组件,可以本地修改成同样的名字替换,也可以在php.ini里面修改调用名字

  5. 一定要重启PHP、重启PHP、重启PHP,重要的事情说三遍,不管用就重启服务器。

  6. 全部修改完成后,在 phpinfo 看到了 SourceGuardian 的相关信息,说明扩展已经生效了
0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧
个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索